Redirection My Performance Center cassée

HP Performance Center
Khap
Messages : 41
Inscription : jeu. 28 juin 2012 17:38

Redirection My Performance Center cassée

Message : #947 Khap
jeu. 16 oct. 2014 16:59

Bonjour à tous !

Nous sommes entrain de changer de serveur ALM sur notre plate-forme Performance Center 11.52 Patch 3 et je rencontre un problème étrange : l'alias utilisé par le lien "My Performance Center" depuis la page d'accueil ALM renvoie une erreur 404.

Via l'alias "https://MonServeurALM/qcbin/loadtest", c'est KO
Mais si j'accède directement à l'adresse vers laquelle l'alias pointe, à savoir "http://MonServeurPC/LoadTest/General/Login.aspx", j'atteins bien le formulaire de connexion. (il n'y a que le serveur ALM en HTTPS)

Il n'y a donc que l'alias qui est dysfonctionnel.

Le serveur PC est bien connecté, joignable, le module System Health dans ALM ne renvoie que du vert.
Le dysfonctionnement est présent aussi bien avec l'ancien serveur ALM qu'avec le nouveau.

Est-ce que quelqu'un a une idée ?

Avatar de l’utilisateur
chilglord
Messages : 107
Inscription : mar. 23 août 2011 18:40

Re: Redirection My Performance Center cassée

Message : #948 chilglord
jeu. 16 oct. 2014 17:06

Salut,

Va dans le Lab management

Au niveau du PC Server, vérifie l'External/Internal URL (sans /qcbin/ il doit y avoir uniquement le nom du host).
Tu changes et fait un reconfigure sur le PCS.

Chilglord

Khap
Messages : 41
Inscription : jeu. 28 juin 2012 17:38

Re: Redirection My Performance Center cassée

Message : #949 Khap
jeu. 16 oct. 2014 19:23

Je pensais pourtant avoir comparé les paramètres sur différents environnements et les avoir vus identiques...
Je n'ai pas dû regarder avec les yeux en face des trous ;)

On verra ça lundi, merci !

Khap
Messages : 41
Inscription : jeu. 28 juin 2012 17:38

Re: Redirection My Performance Center cassée

Message : #950 Khap
mer. 22 oct. 2014 16:20

Voici les détails du serveur PC :

Image

Via la redirection ALM :

Image

Et voici l'accès à l'URL via PC par /loadtest :

Image

J'avoue que je suis perdu.
Deux configurations strictement identiques (mais noms de serveurs différents) dans le lab sur un autre environnement fonctionnent à merveille...

Avatar de l’utilisateur
chilglord
Messages : 107
Inscription : mar. 23 août 2011 18:40

Re: Redirection My Performance Center cassée

Message : #951 chilglord
jeu. 23 oct. 2014 12:23

Si tu accèdes bien en direct au My Performance Center, c'est plutôt un problème de redirection.

Regarde l’install IIS et en particulier le module de redirection.

http://blog.pluralsight.com/windows-server-2008-iis7

chilglord

Khap
Messages : 41
Inscription : jeu. 28 juin 2012 17:38

Re: Redirection My Performance Center cassée

Message : #952 Khap
jeu. 23 oct. 2014 16:24

Fin mot de l'histoire : il me fallait qualifier le nom complet de la machine (avec le domaine derrière) pour que la redirection fonctionne.

J'ai donc remplacé "http://wiin331a" par "http://wiin331a.intra-int.bdf-int.local", et tout roule.
J'imagine que nos DNS sont en vrac en ce moment et que le nom court ne suffisait pas à résoudre l'IP de la machine dans un certain contexte.


Revenir vers « HP Performance Center »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités