Installation & ajout LG ALM 11.04

HP Performance Center
Avatar de l’utilisateur
Ultrapanda
Messages : 13
Inscription : jeu. 21 févr. 2013 10:28

Installation & ajout LG ALM 11.04

Message : #695 Ultrapanda
jeu. 20 juin 2013 14:42

Bonjour,

Je rencontre une difficulté lors de la communication entre ALM-PC et l'ajout d'un nouvel injecteur (virtualisé).

A savoir:
Installation du feature dotnet sur le server.
Install du PC host complet 11.00.
Patch en 11.04.
==> C'est long, mais pas d'erreur.

Démarrage du performance agent service dans le PC runtime settings : domaine/login/mdp de la machine (admin local, je n'ai pas mieux).
Enable terminal dans Performance Center Agent Configuration
==> Jusque là pas de problème.

MAJ fichier host de l'injecteur, du server ALM, des 2 PC server.
==> Ca pingue !

Ajout du host dans le lab management : en mode stand alone, erreur cannot find the remote management agent service
==> Alors que celui est bien démarré, et redémarré pour vérif (started-automatic), sur le server cible.

En mode windows host: host installation is invalid.
Après quelques recherches ; c'est une erreur générique (grml ...) : les fichiers de log dans orchid tmp sont tous à 0kb, le port 8731 est bien en listening...

Quelqu'un aurait il une piste ?
Un oubli ou un "boulet-time" de ma part ? :roll:

Merci à vous.
"Les backups, c'est pour les faibles!"

Avatar de l’utilisateur
Ultrapanda
Messages : 13
Inscription : jeu. 21 févr. 2013 10:28

Re: Installation & ajout LG ALM 11.04

Message : #696 Ultrapanda
jeu. 20 juin 2013 15:09

Ou un port à ouvrir ?
"Les backups, c'est pour les faibles!"

Avatar de l’utilisateur
Ultrapanda
Messages : 13
Inscription : jeu. 21 févr. 2013 10:28

Re: Installation & ajout LG ALM 11.04

Message : #697 Ultrapanda
jeu. 20 juin 2013 17:36

Il semble que cela soit un pb de firewall entre 2 Vlan ...
Encore a valider!
"Les backups, c'est pour les faibles!"

Avatar de l’utilisateur
chilglord
Messages : 107
Inscription : mar. 23 août 2011 18:40

Re: Installation & ajout LG ALM 11.04

Message : #698 chilglord
jeu. 20 juin 2013 18:31

Tu as l'air dans la mouise :-)
Bon déjà, pas la peine d'activer "Terminal Services", ça sert dans des cas bien particulier pour faire tourner des VUsers dans des plusieurs sessions Windows.
Ensuite il faut bien comprendre qu'il y a un package:
- "Host" ou "Load Test Server (LTS)" qui permet d''avoir une machine qui peut être Controler, Data Processor, Load Generator ou une combinaison des 3
- Load Generator Stand Alone (LG SA) qui permet simplement d'avoir une machine Load Generator

Si ton but est de faire un Load Generator, je te conseille d'installer le package LG SA, plus rapide, simple... moins d'emmerdes quoi :-)

Dans le Lab Management (Host) , à la création d'un host, il est impératif de sélectionner le bon type d'installation: Windows Host ou Windows LG SA (il existe aussi Unix LG et UFT depuis la 11.50). Si c'est Windows Host, on doit sélectionner ensuite le "Purpose": LG, DP, CTRL.

Dans ton cas, tu as installer un Windows Host et donc forcement dans le Lab Management il faut sélectionner une installation de type "Windows Host" puis le/s Purpose/s

Sinon,il y a effectivement une tripoté de ports à ouvrir si tu n'utilises pas le MI Listener (mode proxy d'injection ou de monitoring). HP n'a pas fourni de matrice de flux pour la 11.0x. Dans la doc 11.50 il y a des éléments mais c'est pas trop.
Je regarde se que je peux trouver et je tu poste cela dans la foulée.

a+

chilglord

Avatar de l’utilisateur
chilglord
Messages : 107
Inscription : mar. 23 août 2011 18:40

Re: Installation & ajout LG ALM 11.04

Message : #699 chilglord
jeu. 20 juin 2013 19:55

Pour le flux, il faut avoir:

PC Server->ALM Server: 8080 HTTP
PC Server->LTS: 3333, 54245, 8701 TCP
LTS->ALM Server: 8080 HTTP
LTS->PC Server: 80 HTTP
LTS->LTS purpose LG ou LGSA: 5001,5002, 5003, 54245, 54345 TCP
LTS->LTS purpose LG ou LGSA: 139 et 445 TCP

Que du standard quoi :-p

chilglord

Avatar de l’utilisateur
Ultrapanda
Messages : 13
Inscription : jeu. 21 févr. 2013 10:28

Re: Installation & ajout LG ALM 11.04

Message : #700 Ultrapanda
ven. 21 juin 2013 09:24

Salut,.

Pas la super mouise, mais peu de temps pour des opérations (évidemment) non-planifiées dans un planning serré comme un string roccosiffrédien !

OK pour le host, je m'en suis souvenu : simplement, galère de retrouver les bonnes sources avec le patch correspondant ...
OK pour le lab management et le paramétrage Terminal Services.

Le pb ayant été le fameux "mais si, tout est ok au niveau des ports ..." alors que visiblement NON :x
Depuis le temps, je devrais pourtant être habitué ;)

Je dois installer le host puisque nous ne savons pas encore où serons les nouveaux controler ...

Affaire à suivre dés que l'équipe réseau sera disponible sur ce sujet.

Et merci :)
"Les backups, c'est pour les faibles!"

Avatar de l’utilisateur
Ultrapanda
Messages : 13
Inscription : jeu. 21 févr. 2013 10:28

Re: Installation & ajout LG ALM 11.04

Message : #704 Ultrapanda
ven. 28 juin 2013 14:55

C'était bien le réseau qui pêchait ...

Ne pas oublier le port de fourbe:
Performance Center Host HTTP (8731)

Merci ;)
A+
"Les backups, c'est pour les faibles!"


Revenir vers « HP Performance Center »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité